How to use the Tridify BIM Tools in a Unity 2018 HDRP project

In this tutorial you will learn how to use the Tridify BIM Tools in a Unity HD Render Pipeline project.

Explore the benefits of the Tridify BIM Publishing Service and start a FREE 14-day trial (no credit card required)

Setting up HDRP

Create a new Unity project using the High-Definition RP-template.

Delete 'Example Assets' in the Hierarchy and Project windows and delete 'SampleScene' in the Scenes folder (Project > Assets > Scenes). Leave Main Camera, Directional Light, Post-process Volume and Volume Settings in the Hierarchy window.

In the Package Manager (menu: Window > Package Manager > Advanced > Show preview packages) make sure that your High Definition RP package is up to date.

Download and import the Tridify BIM Tools into the project.

Import your model into the project with the Tridify BIM Tools (menu: Tools > Tridify > Conversion Projects). Note that the IFC file has to be processed in the Tridify BIM Publishing Service before the import.

Upgrade project materials to HDRP Materials (menu: Edit > Render Pipeline > Upgrade Project Materials to High Definition Materials).

Save the scene.

 

hdrp-nolight

Step 1

In the Lighting Settings (menu:  Window > Rendering > Lighting Settings) tick Realtime Global Illumination checkbox, untick Baked Global Illumination and untick also Auto Generate checkbox.

Change Surface Type of the Glass material to Transparent (Project > Assets > Floors > Materials).

Select all GameObjects in the Hierarchy window and mark as Static in the Inspector.

Select all window objects using the Search Tool in the Tridify BIM Tools (menu: Tools > Tridify > Search Tool: IFC Product Type, contains, Window) and turn off Cast Shadows in the Inspector. Do the same thing for all transparent glass elements in the scene.

 

hdrp-step1

Step 2

Create lighting with the Tridify Tools. In the Floor Lighting window (menu: Tools > Tridify > Floor Lighting) check that all desired floor and ceiling definitions are green. If not, the definitions have to be made manually by selecting the correct object and defining it. Create Floor Lighting.

To make working easier, you can minimize the 3D icons of the Emitting Lights; on the Scene tab, press Gizmos and adjust their size with the slider.

 

hdrp-step2

Step 3

The Floor Lighting tool creates planes with emissive material to the ceilings. Select EmissiveLights-material (Project > Assets > Scenes) and in the Inspector change EmissiveLights Shader to HDRP/Unlit.

When using Unity version 2018.3.7 (or newer) in HDRP/Unlit Material enable Alpha Clipping. Change Emissive HDR color to white and set the intensity to 5 (this can be adjusted later in realtime).

 

hdrp-step3

Step 4

Change EmissiveLights-material’s Surface Inputs Color Alpha to 0 to make the planes transparent (they will still emit light).

 

hdrp-step4

Step 5

In the Lighting Settings, click Generate Lighting to generate precomputed lightmaps for Realtime Global Illumination. This will take some time depending on the size of the model.

 

hdrp-step5

Step 6

After lightmap generation, the amount of light can be changed in EmissiveLights-material’s Emissive Color HDR Intensity. If more light is needed in some places, Emissive Light-planes can be copied and moved like any other object. In that case lightmaps must be baked again.

 

hdrp-step6

Step 7

Create HDRI Sky Cubemap to add background and environment lighting to the scene. Ready-to-use HDR Cubemaps can be found in the Unity Asset Store (for example, the Unity HDRI Pack).

In the Settings folder (Project > Assets > Settings) - not in the Hierarchy window - select Volume Settings and in the Inspector change Visual Environment Sky Type to HDRI Sky. Click Add component overrides, and add HDRI Sky.

Activate HDRI Sky and add sky cubemap into it.

Volume Settings components Baking Sky, Skybox, Procedural Sky and Exponential Fog (if not used) can be removed or inactivated. Visual Environment Fog Type also can be inactivated (if not needed).

The changes will be seen after Playmode is once clicked on and off (Toolbar > Play/Pause/Step Buttons).

 

hdrp-step7

Step 8

Directional Light simulates sun in the scene. Rotate light and change its intensity to get the desired effect. If some shadows, casted by Directional light, seem to get a strange half-blur effect on them, it might be necessary to change the amount of HD Shadow Settings Max Distance in Volume Settings.

Post-process Volume applies full-screen filters and effects to get more realistic graphics. More can be added in the Inspector (Post-process Volume > Add effect…).

 

hdrp-step8

Step 9

Default materials can be replaced with custom materials by using the Material Replacer in the Tridify BIM Tools . Open the Material Replacer (menu: Tools > Tridify > Material Replacer), drag-and-drop the new material to the correct location and click Apply in Scene.

 

hdrp-step9

 

hdrp-step10

Step 10

By default, objects in the Unity scene will reflect the Skybox. When using reflective materials Reflection Probes are needed to create more accurate reflections. Add a Reflection Probe (GameObject > Light > Reflection Probe) and position it to the room.

The centre of the Reflection Probe (the sphere) should be in the centre of the room and the edges (sides of the box) a little outside the walls. While the Reflection Probe is selected, click Bake in the Inspector to bake reflections. Covering an entire building can take a few probes. 

Read more about using Reflection Probes in Unity: https://docs.unity3d.com/Manual/UsingReflectionProbes.html

 

hdrp-step11

Step 11

Add furniture to the scene. Tridify offers a free HDRP Furniture Pack that you can download from the Unity Asset Store.

Step 12

The Floor Lighting tool in the Tridify  BIM Tools creates not only emissive light planes but also Light Probes. Light Probes capture and use information about light that is passing through the empty space in the scene. Thus, GameObjects that are not marked as Static, can receive bounced light.

 

hdrp-step12

 

Another option is to mark all GameObjects as Static in the Inspector and bake the lights.

 

hdrp-step13

 

Basic things in your scene are now set up. You can continue by adjusting the settings to find out what will work best for your project.