How to set up coordinates in Revit

In this tutorial you will learn how to set up project coordinates in Revit. Project coordinates are used to position the project correctly among different applications; exporting a file from Revit to IFC preserves location.

Explore the benefits of the Tridify BIM Publishing Service and start a FREE 14-day trial (no credit card required)

 

A few things have to be set up in order to represent the project location.

Project Base Point

Revit_coordinates_2
The project base point defines the origin (0,0,0) of the project coordinate system. It also can be used to position the building on the site and for locating the design elements of a building during construction. Spot coordinates and spot elevations that reference the project coordinate system are displayed relative to this point.

Project Survey Point

Revit_coordinates_1
The survey point represents a known point in the physical world, such as a geodetic survey marker. The survey point is used to correctly orient the building geometry in another coordinate system, such as the coordinate system used in a civil engineering application.

It is advisable that Project Survey Point has some project-sensible values and the Project Base Point is assigned to match the Survey Point.
Learn more about how to Move Project Base Points and Survey Points

To make these points visible:

  1. Click View tab > Graphics panel > Visibility/Graphics
  2. On the Model Categories tab of the Visibility/Graphics dialog, scroll down to Site
    and expand it
  3. To display the project base point, select Project Base Point
  4. To display the survey point, select Survey Point
  5. You can also click Reveal Hidden Elements on the View Control bar (at the bottom of the view window) to turn on the visibility of the project base point and survey point in a view
  6. To display the internal origin, select Internal Origin

Moving the project base point

Before moving the project base point, determine whether you should move it when it is clipped or unclipped:

  • To move the entire model in relation to the survey point, move the clipped project base point. Clipping ensures that relative location of project base point and project (building) is fixed.

  • To move the project base point to another location on the model, move the unclipped project base point. Moving the unclipped project base point allows you to set a location for it independently from the project (building).

  • To return the project base point to the internal origin, unclip it and use the Move to Startup Location tool.

To move the project base point:

  1. In the site plan view or another view that displays the project base point, select it.

  2. Click the clip to change its state to clipped or unclipped, depending on how you want to move the project base point.

  3. Drag the project base point to the desired location.
    As an alternative, using the Properties palette or the Project Base Point fields in the drawing area, enter values for N/S (northing), E/W (easting), Elevation, and Angle to True North. Setting the angle to True North is the same as using the Rotate True North tool.

  4. If you unclipped the project base point, clip it again.

  5. Optional: To ensure that the project base point does not move inadvertently, pin it in place by clicking Modify > Modify panel > Pin.

More info on moving the Project Base Point and Survey Point is available from Autodesk.

 

Survey Point and Project Base Point placed at the same location:

 

Revit_coordinates_3

 

Revit_coordinates_4

 

Project base point being placed away from Survey Point:

 

Revit_coordinates_5

Site has coordinates and location settings preserved after IFC export. Global X and Global Y display coordinates for first point of site’s topographic surface.

 

Revit_coordinates_6

 

Revit 2020.2 and later

To make internal origin visible, click View tab > Graphics > Visibility/Graphics, or use the VG hotkey. Then search for Site under the Model Categories, expand it, and select Internal Origin.

Starting from the version 2020, Revit displays the Internal origin in 3D view.
More info from Autodesk: About the Internal Origin

Revit_coordinates_7

Click Reveal Hidden Elements to make it visible. If you have several models linked, their project origins will be visible in grey.

 

*Some Autodesk content included in this tutorial