How to install the Tridify BIM Tools for Unity

In this tutorial you'll learn how to install the Tridify BIM Tools for Unity, after which you'll be able to import your processed IFC files with BIM data attached straight to Unity software.

Explore the benefits of the Tridify BIM Publishing Service and start a FREE 14-day trial (no credit card required)

 

1. Download the Tridify BIM Tools for Unity

Once your file is processed in the Tridify BIM Publishing Service you can access it in Unity. For this you'll need to install the Tridify BIM Tools for Unity. You can download them here or via the Unity Asset Store.

2. Import asset

In Unity go to Assets > Import Package > Custom Package and locate the package file to import. Or use Window > Asset Store to download and import the package. Please note that you have to sign in to Unity before you download the asset. Otherwise Unity will import the old version of the BIM Tools from your Temp folder.


After the upload, a window will appear that allows you to select your desired components of the package. It is recommended that you import all.


Click Import.

 

BIM_Tools_install_1

 

The Tridify menu should appear under the Tools menu. If not, make sure you are using .NET 4.X as the Scripting Runtime Version (Edit -> Project Settings -> Player -> Other Settings -> Configuration) and restart Unity.

 

BIM_Tools_install_2